Investigating impact of AWS us-east-1 issues

Incident Report for Contrast Security

Resolved

The incident affecting has been fully resolved. All systems are now operating normally, and stability has been confirmed.

If you have any questions, concerns, or would like to discuss this issue further, please don’t hesitate to reach out to us at support@contrastsecurity.com.
Posted Oct 20, 2025 - 19:02 UTC

Monitoring

A fix has been implemented for all impacted environments. We are monitoring system performance closely to confirm stability before closing this incident. Customers should already be seeing normal service levels.
Posted Oct 20, 2025 - 17:41 UTC

Update

We have identified the cause of the issue and are working on a resolution. We are seeing success in some environments and continue to work on resolution for other environments. We currently do not have an estimate for the full resolution. We will continue to provide updates every hour or sooner as new information becomes available.
Posted Oct 20, 2025 - 16:42 UTC

Identified

We have identified the cause of the issue and are working on a resolution. We currently do not have an estimate of the resolution. We will continue to provide updates every hour or sooner as new information becomes available.
Posted Oct 20, 2025 - 16:06 UTC

Investigating

We are investigating the impact of the current AWS issues on our SaaS environments hosted in the AWS us-east-1 region. While Contrast's core functionality currently appears to unaffected. We're assessing any unforeseen issues to our services. This incident will be updated with findings.
Posted Oct 20, 2025 - 15:29 UTC
This incident affected: app (Contrast Server, Protect, ADR, Integrations), CS-PROD-U002C (Contrast Server, Integrations), eval (Contrast Server, Protect, ADR, Integrations), CS-PROD-U006M (Contrast Server, Protect, ADR, Integrations), and CS-PROD-U008P (Contrast Server, Integrations).